欢迎使用交易开拓者终端（CTP版）

 下一页

欢迎使用交易开拓者

交易开拓者(TradeBlazer)是一款为中国期货市场专业投资用户开发的金融投资软件，它集中了实时行情，技术分析， 快捷交易及程式化交易的功能。通过使用交易开拓者，用户可以简单，快速的将自己的交易思想转化为计算机代码，让计算机帮助用户实现价值。

我们致力于为期货行业的投资者提供一个实现盈利的工具，但并不保证该软件能为所有的使用者带来盈利， 希望使用者能够通过使用系统，建立并优化自己的交易思想，形成自己的交易策略。

感谢您选择交易开拓者，希望您能够通过使用该系统找到乐趣，并能创造更多价值。

交易开拓者快速链接

  • 关于交易开拓者

  • 快速入门

  • 系统基础

  • 行情报价


系统简介

交易开拓者终端(CTP版)

交易开拓者终端（CTP版）是交易开拓者针对上期柜台独立开发的一个版本，它承载了交易开拓者专业版软件的功能，并且加入了银期转帐、策略易等等强大的功能，并且提升了行情速度和交易速度。

功能特色

  • 多 化繁为简，多帐户管理、交易所套利单的支持。

  • 快 快马加鞭，快车道、一键平仓、一键撤单。

  • 好 独具匠心，套利宝、价差下单、策略易。

  • 省 省时省心，交易助手、批量下单、批量触发单。

    关于交易开拓者其他版本

    交易开拓者(超强版)

    交易开拓者(TradeBlazer) 是一款针对中国期货市场投资用户而开发的投资工具，集中了实时行情，技术分析，快捷交易，套利，多帐户管理及程序化自动交易等功能。交易开拓者突破传统交易平台的限制，一切以交易为核心，所有功能都围绕交易而设置。并提供强大的、先进的程序化自动交易功能，善用该功能将能有效的提升您的交易境界。

    • 强大的公式支持系统，方便用户实现交易思想，编写自己的交易策略。

    • 独有的交易策略测试引擎，方便用户测试及优化交易策略。

    • 领先的策略交易体系，实时数据驱动和自动交易功能，可完全实现自动交易。

    • 面向用户的快速交易工具，动态帐户和风险监控机制。

    • 多种方式的套利功能，直观轻松的实现套利交易。

    • 独有的多帐户管理界面，对多帐户的同步控制方便快捷。

    • 详尽的真实交易统计报表，方便您直观的总结交易思想。

    • 完善的图表体系设计、分析工具与交易功能的动态交互。

    • 工作区管理机制和个性化模板应用，方便您定制自己的界面和风格。

    更多可以访问交易开拓者官网


系统配置

最低系统配置

  • CPU: Intel或AMD双核1.5GHZ以上

  • 硬盘: 1G及以上可用空间

  • 内存: 512M及以上

  • 显示器: 15吋彩显，分辨率1024*768

  • 操作系统: WindowsXP sp2及以上系统

  • 互联网: 宽带1Mbps以上

推荐系统配置

  • CPU: Intel或AMD双核2.5GHZ以上

  • 硬盘: 10G及以上可用空间

  • 内存: 1G及以上

  • 显示器: 17吋彩显，分辨率1280*1024

  • 操作系统: WindowsXP sp2及以上系统

  • 互联网: 宽带2Mbps以上

  • 其他：有声卡和音箱等多媒体设备


寻求帮助

交易开拓者是一个专业金融投资工具，需要您多些耐心，慢慢地去和它沟通。在使用交易开拓者的过程中，无论您遇到什么问题，我们都将为您提供帮助。为了有效的解决问题，在您和我们直接联系前，您可以先采取以下方法获取帮助：

查看连机帮助

  1. 打开帮助窗口: 如果需要获得帮助，只需单击“帮助”菜单中的“帮助指南”，系统将显示“帮助”窗口。或者直接按键盘中的“F1”键。通过鼠标单击系统任何窗口中的“帮助”按钮，都可以打开“帮助”窗口，并直接定位到与此窗口相关的帮助说明页上。

  2. 帮助窗口中的索引功能: 单击“索引”选项卡，在“键入要查找的关键字”文本框中，输入您要查找的问题的关键性字、词或短语，回车即可获得相关帮助信息条目，选中您所需要的帮助内容进行查阅。

  3. 帮助窗口中的搜索功能: 要在“帮助”窗口中键入问题，请单击“搜索”选项卡，在“输入要查找的单词”文本框中，输入您要查找的问题的关键性字、词或短语，点击列出主题，就会在主题框里显示您要查找的主题，双击标题就可查看相关内容。

  4. 其它： 要查看工具栏按钮的名称，可将鼠标置于该按钮上，直到提示信息出现。

其他途径

选择菜栏单“帮助”下的“常见问题解答”，查看有关交易开拓者的常见问题解答。如果没有找到问题的解决方法，您还可以将您的疑问，作为“用户问题”提交，即可将您的问题反馈给我们，我们将尽快给您解答。

也可访问系统交易论坛您可以在这里找到更多的例子以及各种问题的答案。

如果您的问题还是没有解决，请与我们的技术支持联系，我们会以最快的速度回复您的问题。

感谢您选用交易开拓者，我们将用心的为您提供最有价值的服务！


安装和卸载

下载

  • 用户可以登录交易开拓者下载页面，找到要下载的相关文件，直接点击下载。

  • 如果您是老用户，如果有新版本发布，系统在登录时会提示您下载最新版本，此时点击下载按钮即下载。

安装

  • 成功下载完交易开拓者安装程序之后，您可以双击安装文件进行安装，按照安装向导的提示，只需要点击几下按钮，即可轻松完成。

卸载

  • 单击“开始”按钮，指向“程序”子菜单，然后再用鼠标指向“TBTerminal”子菜单，最后单击“卸载交易开拓者终端（CTP版）”，程序会自动将用户计算机上安装的交易开拓者程序及其快捷方式删除。

  • 单击“开始”按钮，选择“控制面板”子菜单，找到并双击“添加/删除程序”图标，在“安装/卸载”选项卡页面的列表中上找到“交易开拓者终端”项，然后单击“删除”按钮即可。


系统登录

运行交易开拓者终端（CTP版）

成功安装交易开拓者之后，您就可以开始使用交易开拓者了，点击桌面或应用程序组中"交易开拓者"快捷方式，将弹出系统登录界面。

经纪商选择

如果您是上期柜台的用户，请选择您所开户的期货经纪商名称。如果在经纪商列表中没有找到您所在的经纪商名称，您可以点击[设置]自行添加。最后登录的经纪商信息和分组将会设为默认登录信息。

帐号登陆

如果您已经有上期柜台的登录帐号，可以直接在登录界面中输入帐号和密码，并点击"登录"按钮。最后的登陆帐户信息将会设为默认登陆信息。

注意: 如果系统登录时网络不通，您将不能够使用该系统。但在系统使用过程中出现网络问题，您仍然可以脱机使用交易开拓者,但脱机情况下只能使用部分功能。当网络恢复正常的情况下，系统会自动恢复连接。


连接交易帐户

多交易帐户登录

在登录系统之后，您可以在工具栏上找到一个按钮"帐户登录"，点击该按钮，将会弹出一个对话框，如下图所示：

选择您想要登录的交易帐户，输入密码，点击"登录"按钮，就完成了一个交易帐户的登录，登录之后您就可以对该帐户进行各项操作。您也可以勾选多个，同时登录多个交易帐户。选中"保存密码"复选框，下次登录时可以不输入密码。


主界面介绍

主界面示意图

主界面内容说明

  • 菜单: 包含系统和各个功能模块的设置；

  • 工具栏: 包含帐户登录，各功能模块等快捷按钮，用户只要选中某个按钮，系统可以迅速打开相对应的功能和模块窗口；

  • 帐户管理: 对用户的交易帐户信息进行管理，包括资金，持仓，委托等信息。

  • 时间状态栏: 包括用户登录交易开拓者终端时间（左边）和各个交易所时间（右边）。


经纪商设置

添加经纪商地址

您可以通过点击[帐户菜单]的经纪商设置,将会弹出一个对话框，如下图所示:

从期货经纪商获得CTP券商ID、行情前置机和交易前置机地址后，按以下步骤添加CTP地址：

  • 在右上角[经纪商维护]中，将券商ID填入ID一栏，名称填入期货经纪公司名称，点击“添加”按钮。

  • 在左上角[经纪商选择]中，选择我们要添加的期货经纪商，在窗口下方分别输入不同运营商（电信、联通）的交易前置机地址（端口）和行情前置机地址（端口）。

经纪商设置中的维护系列按钮包含以下内容：

  • 添加：根据编辑框中的信息添加新的经济商或分组；

  • 修改：修改经纪商信息；

  • 删除：删除分组或经纪商；

  • 设为默认：设置当前选中分组为默认分组。


特色功能

交易开拓者提供了一系列的特色功能，方便用户进行分析和交易。

主要的特色功能包含以下模块：批量下单，批量触发单，套利宝、快车道，键盘手，帐户管理，策略易，消息中心等。

批量下单

提供多帐户批量下单的功能，提高多帐户交易的效率。

详细介绍请参见批量下单。

套利宝

提供普通套利和蝶式套利的自动下单功能，还可以进行自动跨月换仓操作，并提供分布建仓等高级功能。

详细介绍请参见套利宝。

价差下单

提供普通套利和蝶式套利的手动下单功能，还可以进行跨月换仓操作，并有实时的价差买卖盘图表，可直观的进行手动套利交易。

详细介绍请参见价差下单。

快车道

提供直观快捷的交易功能，可通过按1，2，3，4键实现委托，并有自动识别持仓，不需要您再设置开平仓选项。

详细介绍请参见快车道。

键盘手

提供快捷的键盘交易功能，可以使用快捷键进行快速设置，大大提高了交易的速度。

详细介绍请参见键盘手。

交易助手

提供未成交单的自动监控及后续处理功能。

详细介绍请参见交易助手。

帐户管理

对用户的交易帐户信息进行管理，包括资金，持仓，委托等信息。可对多帐户进行集中管理，并在页面中提供了快速交易的通道。

详细介绍请参见帐户管理。

策略易

策略易是功能强大的自动化交易模块，它能帮助您创建自己的交易策略。通过组合普通的条件与设置，使您能够很容易并且直接的用简单设置表达自己的交易规则和行为。

交易开拓者终端根据您的设置，执行特定的交易动作，完成您的交易思想。

详细介绍请参见策略易。

消息中心

是为了统一管理各类报警功能和系统、行情、交易消息提示而设计的特色功能，实现了多通道通知方式和个性化设置功能。

详细介绍请参见消息中心。


特色指标说明

快速入门 - 特色指标说明

特色指标

交易开拓者从实战角度提供了大量自定义的指标，便于行情观察及风险控制

主要的特色指标：多空比率、杠杆率、涨幅C、涨幅C%、多空市值等

行情报价

涨跌C ：最新价相对于上一日收盘价的涨跌

涨幅C%：最新价相对于上一日收盘价的涨幅

涨跌S：最新价相对于上一日结算价的涨跌

昨仓：上一日收盘持仓量

帐户汇总

静态权益：等于上一日结算后的账户余额，包含保证金

动态权益：最新账户余额，包含保证金

多空比率：风险指标反映风险暴露情况，等于：(多头汇总市值-空头汇总市值)/动态权益

杠杆率：反映账户权益与合约资产波动的关系指标，等于：净市值/动态权益。例如：杠杆=0.5，合约资产波动10%，账户权益波动=10%*0.5=5%，若杠杆=3，则合约资产波动10%，账户权益波动=10%*3=30%.注:锁仓不参与计算

持仓市值：即净市值，反映总体的单边市值汇总。注:锁仓不参与计算

风险度：保证金总额/动态权益

持仓信息

总持仓：反映总体持仓情况，等于：多头持仓手数-空头持仓手数

均价：反映成本价格，等于：持仓成本总和 /总持仓量

净市值：即该合约单边净市值，锁仓不纳入计算,等于(多头市值-空头市值)的绝对值

杠杆率：反映持有合约净资产与客户资产的比例，等于：净市值/动态权益 。注:锁仓不参与计算

买持仓：多头持仓

买均价：多头持仓的成本价

多头市值：多头持仓总市值

卖持仓：空头持仓

卖均价：空头持仓的成本价

空头市值：空头持仓总市值

当日交易

滑价：多头滑价=委托价格-成交均价，空头滑价=成交均价-委托价格

注释：记录该笔委托来至哪个功能模块，以便客户查询智能交易执行情况，一般来源有快车道、键盘手、策略易、套利宝等


退出系统

尚未登录系统

如果您在“欢迎登录交易开拓者”的界面，直接点击“退出”按钮即可。

已经登录系统

如果您已经进入了交易开拓者系统，要退出程序，有以下几种方法：

    1. 直接按快捷键Alt+F4；

    2. 用鼠标单击系统菜单[文件]-[退出]菜单项；

    3. 用鼠标点击窗口右上角的关闭按钮。

交易开拓者退出之前，系统会弹出是否保存对工作区的修改，用户可根据您自己的需要选择。

相关链接:

系统登录

系统菜单

主界面介绍


系统菜单

在无工作区打开情况下，系统菜单有以下几个子菜单：系统、帐户、行情、交易、查看和帮助。以下详细描述个子菜单内容：

系统菜单

  • 系统设置: 打开系统设置；

  • 锁定程序: 将软件锁起，需要密码才能启动；

  • 退出: 关闭软件；

帐户菜单

  • 帐户登录: 显示多帐户登录窗口；

  • 经纪商设置: 显示经纪商设置窗口；

  • 结算单: 显示结算单；

  • 银期转帐: 显示银期转帐窗口；

行情菜单

  • 我的键盘: 打开我的键盘；

  • 商品选择: 打开商品选择窗口；

  • 字段选择: 打开行情报价字段选择窗口；

交易菜单

  • 批量下单: 打开批量下单窗口；

  • 批量触发单: 打开批量下单窗口，操作默认选择触发单；

  • 套利宝: 打开套利宝窗口；

  • 价差下单: 打开价差下单窗口；

  • 策略易: 打开策略易窗口；

  • 交易助手设置: 打开交易助手设置。

查看菜单

  • 快车道: 打开快车道设置面板；

  • 帐户管理: 显示或者隐藏帐户管理窗口；

  • 信息中心: 打开信息中心窗口；

  • 工具栏: 显示或者隐藏工具栏；

  • 状态栏: 显示或者隐藏状态栏。

帮助菜单

  • 索引...: 打开帮助文件的索引页；

  • 查找...: 打开帮助文件的查找页；

  • 帮助指南: 打开帮助文件的目录页；

  • 常见问题解答: 打开网站的常见问题解答；

  • 联系我们: 打开网站的联系我们页面；

  • 操作小技巧...: 打开操作小技巧窗口，了解一些常用的操作技巧；

  • 关于TradeBlazer: 打开关于TradeBlazer窗口，了解版本和版权等信息。


工具栏

系统工具栏主要有以下和视窗模块无关的按钮，其他和视窗模块相关的按钮使用放到相关章节：

  • 帐户登录: 选择并登录交易帐户；

  • 快车道: 打开快车道设置面板；

  • 键盘手: 打开键盘手设置面板；

  • 帐户管理: 显示或者隐藏帐户管理窗口；

  • 我的键盘: 显示软键盘；

  • 商品选择: 打开商品选择窗口，并且勾选所需要查看的品种合约；

  • 字段选择: 显示字段选择窗口，可以选择行情报价中显示的字段；

  • 批量下单: 打开批量下单窗口；

  • 批量触发: 打开批量触发单窗口；

  • 套利宝: 打开套利宝窗口；

  • 价差下单: 打开价差下单窗口；

  • 策略易: 打开策略易窗口；

  • 交易助手: 启动或者停止交易助手；

相关链接:

我的键盘

帐户管理


我的键盘

我的键盘是交易开拓者中提供商品代码选择和技术分析输入的工具，您可以在行情报价及其他设置窗口中调入我的键盘。

我的键盘可以通过点击工具栏或窗口中的按钮调入，我的键盘显示之后，您可以在输入框中输入任意数字和字母，我的键盘会根据输入字符自动过滤代码。您可以继续输入直接定位到某个代码，也可以通过上下箭头进行定位，定位到想要选择的代码后，回车即可完成代码的输入。

您也可以通过鼠标点击我的键盘中的按钮来进行字符输入，用鼠标单击来进行代码选择。


消息中心

消息中心是交易开拓者的提供消息提示和消息管理的模块，主要功能是处理报警消息和交易消息。

您可以通过系统菜单[查看]-[消息中心]显示或隐藏消息中心，也可以通过双击Windows任务栏图标打开。消息中心的基本信息如下图所示：

消息中心界面包括以下内容：

  • 菜单: 显示消息中心的菜单项，可通过菜单项进行所有消息中心相关操作；

  • 工具栏: 显示常用的操作按钮，可进行页面设置、消息设置、字段设置及字体放大缩小等；

  • 消息内容区: 用列表方式显示当前分类的所有消息；

  • 消息标签页: 可通过点击消息标签页进行消息内容区的切换；

  • 状态栏: 显示操作的一些提示信息。

页面设置

通过菜单或工具栏，可以打开页面设置对话框，页面设置对话框主要进行颜色和字体的设置。

字段设置

通过菜单或工具栏，可以打开字段设置对话框，报警消息页和交易消息页分别有自己的字段设置对话框。在此可进行字段选择和顺序的设置。

消息设置

通过菜单或工具栏，可以打开报警设置/交易设置对话框，报警消息页和交易消息页分别有自己的消息设置对话框。

消息设置页面包括以下内容：

  • 消息保留设置: 可按日期或条数保存消息，并可设置相关参数；

  • 新消息到达: 可选择是否弹出信使；

  • 信使风格: 选择信使风格及停留时间，共有三种信使风格。

以下是其中一个信使显示的示意图：

在消息内容区显示的消息中，列表的第一列显示了一个图标，该图标表达了以下含义：

  • 新到消息: 新消息标志，新消息到达，明显的红色感叹号；

  • 未读消息: 未读消息标志，消息中心中还有未看过的消息；

  • 已读消息: 已读消息标志，阅读后标志已读。

默认报警设置

在报警页面的报警设置中，包含了一个报警默认设置页面。该页面是交易开拓者的默认报警设置，在此设置的信息，可在字段报警，技术分析报警和画线工具报警等地方调用。


系统设置

系统设置是对交易开拓者使用过程中的一些基本参数进行设置的窗口，您可以通过快捷键F8、系统菜单[系统]-[系统设置]打开。

系统设置包括以下两个页面：交易和安全。如下图：

交易

交易页面包含以下内容：默认和数量两部分，分别对默认设置和数量等进行设置。

默认

  • 默认帐户: 多交易帐户的情况下，交易模块打开时的默认选择帐户；

  • 默认显示触发单确认页面：选中该复选框，交易师下触发单将弹出确认页面；

  • 默认显示成交回报页面：选中该复选框，有成交信息时，将会自动弹出成交回报页面；

  • 触发单价格自动生成：选中该复选框，设置触发单时，价格的默认设置。

风险

  • 使用单笔上限: 设置每笔上限的手数。

  • 监控撤单次数: 设置监控撤单的次数进行弹出警告或者停止撤单。

  • 监控期指开仓手数: 设置监控期指开仓手数进行弹出警告或者停止开仓。

安全

  • 密码保护: 对延时锁屏的选项及时间进行设置，当指定时间内系统无操作将会锁住软件界面，您需要重新输入登录密码才能回到原操作界面；

声音

通过点击[设置]按钮打开声音设置对话框，在此可对各种事件设置声音。


快捷键

快捷键 | 所属模块 | 描述
F1 | 全局 | 打开联机帮助。
F2 | 全局 | 打开批量下单窗口。
F3 | 全局 | 打开套利宝窗口。
F4 | 全局 | 打开价差下单窗口。
F5 | 全局 | 显示或隐藏快车道。
F6 | 全局 | 显示或隐藏帐户管理。
F7 | 全局 | 显示或隐藏消息中心。
F8 | 全局 | 调入系统设置界面。
F9 | 全局 | 调入交易助手。
F10 | 全局 | 调入交易帐户登录界面。
F11 | 全局 | 调入经纪商设置界面。
F12 | 全局 | 锁定程序。
Esc | 全局 | 退出某些操作对话框。
Enter | 全局 | 执行选中的动作或进行项目选择。
Alt+F4 | 全局 | 关闭交易开拓者。
Alt+S | 全局 | 打开系统菜单[系统]。
Alt+A | 全局 | 打开系统菜单[帐户]。
Alt+V | 全局 | 打开系统菜单[视图]。
Alt+Q | 全局 | 打开系统菜单[行情]。
Alt+T | 全局 | 打开系统菜单[交易]。
Alt+V | 全局 | 打开系统菜单[查看]。
Alt+H | 全局 | 打开系统菜单[帮助]。
Alt+F4 | 全局 | 退出交易开拓者终端。
上箭头 | 行情报价 | 选中上一行，如果到第一条则选中最后一条。
下箭头 | 行情报价 | 选中下一行，如果到最后一条则选中第一条。
左箭头 | 行情报价 | 除固定字段之外，其他列向右移一格。
右箭头 | 行情报价 | 除固定字段之外，其他列向左移一格。
Enter | 行情报价 | 切换到分时图。
Delete | 行情报价 | 删除选中行。
Home | 行情报价 | 选中第一行。
End | 行情报价 | 选中最后一行。
PageUp | 行情报价 | 向上翻一页。
PageDown | 行情报价 | 向下翻一页。


主界面

行情报价是交易开拓者专为显示动态行情设计的行情揭示系统，拥有强大的行情订阅和检索功能。

行情报价主界面如下图所示：

您可以点击标题栏的某一个字段进行排序，再次点击，将会切换升序/降序。

您可以拖拽一条报价记录，改变排列顺序。

您可以选中一条报价记录，右键菜单进行相关操作。

您可以按照快捷键进行快捷操作，还可以试试鼠标滚轮。


工具栏

行情报价窗口被激活之后，将会在系统工具栏之后添加自己的按钮，如下图所示：

  • 商品选择: 打开商品选择对话框，设置当前显示的商品列表；

  • 字段选择: 打开字段选择对话框，设置当前显示的字段列表；


右键菜单

在行情报价中右键单击，将会弹出右键菜单，包括以下几部分：

  • 模板: 行情报价的显示风格模板，目前包括以下几种风格：黑色风格、经典白色、现代黑色、现代蓝色、现代绿色和现代卡其；

  • 字体大小: 行情报价的显示字体大小，目前包括以下几种：最大、较大、中、较小和最小，还可以选择字体粗细；

  • 刷新频率: 选择行情报价刷新频率快慢；

  • 删除: 按Delete键可直接删除当前选中的行；

  • 保存到文件: 将行情报价导出保存到文件；

  • 帮助: 打开行情报价的联机帮助。


商品选择

商品选择对话框为行情报价模块提供商品选择的功能，通过点击行情报价工具栏的商品选择按钮可打开。

  • 在商品选择对话框的左边树形列表中，勾选商品代码，点击[确认]按钮，即可完成商品的选择。

  • 勾选价差合约后,将在左边的合约树中出现价差合约。(如图)

  • 您可以通过勾选根节点快速选择代码。


字段选择

字段选择对话框为行情报价模块提供字段选择的功能，通过点击行情报价工具栏的字段选择按钮可打开。

字段选择对话框分为两个列表，左边为可选项列表，右边为应用项列表，您可以通过点击中间的按钮进行操作，也可以直接双击项目进行添加和删除。

在字段选择界面右上角还可以设置每个字段的宽度及固定字段的个数。

在完成操作之后，点击[确认]按钮，即可将选择的字段应用到行情报价中。


套利宝

提供两个商品或三个商品的自动价差交易，可实现跨期套利，跨市套利，蝶式套利及跨月换仓等。

您可以通过点击[工具栏]的[套利宝]按钮打开套利宝对话框。

套利宝主界面如下图所示：

价差下单的窗口包含以下内容：

  • 帐户：帐户下拉选择框，选择当前的交易帐户；

  • 模板管理：点击该按钮显示模板管理的菜单；

  • 蝶式套利：点击该按钮将切换到蝶式套利；

  • 跨月换仓：点击该按钮将切换到跨月换仓；

  • 商品选择：要进行交易的商品，先选择交易所，再选择商品代码；

  • 商品数量：对要进行交易的商品设定数量，将根据该比例计算价差；

  • 单笔数量：每次行情触发时交易的数量，实际对每个商品的交易数量会根据比例和单位自动设置；

  • 最大仓位：对价差进行多头或空头交易的最大持仓限制；

  • 多头仓位和空头仓位：把价差作为一个单独的价格来看待，我们可以对它进行做多和做空两种交易，做多即买入商品一，卖出商品二，做空即卖出商品一，买入商品二。 这里的仓位应该要填入帐户的真实套利仓位，初次交易填入0，在交易的过程中退出该模块再次进入时，需手工输入当前的实际仓位。该参数应为单笔数量的整数倍，并小于等于最大仓位；

  • 下单价格偏移值：买入使用叫卖价，卖出使用叫买价，在这个基础上，为了保证成交，可增加一定的偏移值；

  • 分步建仓：设定分步建仓的间距，以及每步开仓的头寸；

  • 下单确认：选择该复选框，交易时会弹出下单确认框。需要快速下单时可取消选择该复选框，此时将会直接发送委托；

  • 启动按钮：点击该按钮，即可启动价差下单的监控，您可在中途暂停并进行参数修改。

跨月换仓模式下，只能选择平仓，此时需在多空头寸处填入已有的头寸，然后设定平仓位置，多空都是相对于商品A而言。按照图上的商品举例，多头平仓即对a0905卖出平仓，对a0909买入开仓。

注意: 价差下单都是按照投机类型，同时发出两到三笔委托，发送的委托并不能确保成交，如果配合使用价位偏移值和交易助手，可实现绝大部分委托的成交，避免单边头寸的出现。


快车道

快车道提供单键交易的功能。

您可以通过点击交易开拓者终端CTP版工具栏的快车道按钮显示快车道界面，还可以通过拖拽的方法切换显示的位置，可以放到行情报价的左边或右边。

快车道主界面如下图所示：

快车道的窗口包含以下内容：

  • 帐户选择树：从列表中选择要进行交易的帐户；

  • 买入，卖出按钮：点击按钮，发送委托单到交易所；

  • 数量：可以选择自定义或输入数量，自定义情况下可详细设置多帐户每个商品的交易数量；

  • 价格：下单价格偏移值：买入使用叫卖价，卖出使用叫买价，在这个基础上，为了保证成交，可增加一定的偏移值；

  • 成交后自动生成止赢单：开仓委托单成交后，将会按照设置自动生成止赢单；

  • 自动开平：选择自动开平，将会根据实时的持仓自动选择开仓还是平仓；

  • 一键下单：选择一键下单后，将会启动0，1，2，3，4数字键快速交易；

  • 下单确认：选择该复选框，交易时会弹出下单确认框。需要快速下单时可取消选择该复选框，此时将会直接发送委托。

注意: 启动一键下单，并取消下单确认的情况下，委托会非常迅速，也容易造成误操作，请只在必需的时候才这样设置。


键盘手

键盘手提供快速使用键盘交易的功能。用户可以使用回车键或者上下键，在交易设置中快速切换设置焦点进行交易设置。

您可以通过点击交易开拓者终端CTP版工具栏的键盘手按钮显示键盘手界面，还可以通过拖拽的方法切换显示的位置，可以放到行情报价的左边或右边。

键盘手主界面如下图所示：

键盘手的窗口包含以下内容：

  • 帐户：输入帐户号，系统会自动匹配补全帐号，或者从列表中选择要进行交易的帐户；

  • 买卖方向选择：买卖方向选项分别对应键盘上的数字键：1 - 买入，3 - 卖出；

  • 开平仓的选择：开平仓选项分别对应键盘上的数字键：1 - 开仓，2 - 平仓，3 - 平今仓；

  • 数量：可以选择自定义或输入数量，自定义情况下可详细设置多帐户每个商品的交易数量；

  • 价格：下单价格偏移值：买入使用叫卖价，卖出使用叫买价，在这个基础上，为了保证成交，可增加一定的偏移值；

  • 自动开平：选择自动开平，将会根据实时的持仓自动选择开仓还是平仓；

  • 下单确认：选择该复选框，交易时会弹出下单确认框。需要快速下单时可取消选择该复选框，此时将会直接发送委托。

  • 自动焦点跳转：选择自动焦点跳转后，设置完每一项的设置后，不需要按回车键，焦点会自动跳转到下一个可编辑选项上；

  • 下单按钮：点击按钮，发送委托单到交易所；

注意: 选中激活交易开拓者终端软件后，点击数字键盘上的“.”，快速激活键盘手交易面板，并且可以使用回车键或者上下键快速切换设置项。


批量普通单

提供多帐户批量下普通单的功能，提高多帐户交易的效率。

您可以通过点击[工具栏]的[批量下单]按钮打开批量下单对话框。

批量下普通单主界面如下图所示：

批量下单的窗口包含以下内容：

  • 帐户选择树：从列表中选择要进行交易的帐户；

  • 商品选择：要进行交易的商品，先选择交易所，再选择商品代码；

  • 其他设置：设置交易的开平仓和投机保值参数，以及委托单的时效；

  • 数量设置：交易的数量设置，先选择数量设置类型，包括以下五种：按自定义数量，按自定义倍数，按指定手数，按指定资金数，按资金比例。然后再根据参数计算出每个帐户的交易数量；

  • 操作类型：可以选择即时发送和触发单交易，即时发送的界面如上图。触发单更多信息请看批量触发单

  • 价格设置：设置此次交易的委托价格，当选中[使用叫买/卖价]复选框，可使用叫买/卖价格做为委托价格，并可以在加上N个点的偏移值，尽可能的保证成交。应用原则为：买入使用叫卖价+N个点偏移，卖出使用叫买价-N个点偏移；

  • 下单确认：选择该复选框，交易时会弹出下单确认框。需要快速下单时可取消选择该复选框，此时将会直接发送委托；

  • 交易按钮：点击买入/卖出按钮，即可发送委托。

自定义数量

当数量设置选择按自定义数量类型，将会出现[自定义...]按钮，可单击该按钮打开自定义数量设置界面，如下图所示：

自定义数量设置的窗口包含以下内容：

  • 名称：当前数量设置的名称；

  • 帐户：要进行数量设置的帐户，从下拉列表中选择；

  • 商品：要进行数量设置的商品，先选择交易所，再选择商品代码；

  • 数量：上述帐户及商品默认的交易数量，单位为手；

  • 列表：显示当前状态下保存的的设置项,可通过点击[全部设置]/[当前商品]按钮对内容进行切换；

  • 添加：在填写好上述信息之后，点击[添加]按钮，即可将该默认设置加入列表中。如果存在相同的记录，则修改原记录的数量为当前设置数量；

  • 删除：先在列表中选择要删除的项目，然后点击[删除]按钮，即可将该项设置删除；

  • 内容切换：通过点击[全部设置]/[当前商品]按钮对内容进行切换，分别显示当前传入商品的设置项或所有设置项。


批量触发单

触发单是交易开拓者特有的交易方式，触发单是指用户设置条件，将触发单提交到交易服务器，当设定条件满足情况，交易服务器会自动发送委托到交易所。触发单可以帮助解决用户盯盘的辛苦，及手动发单的速度问题。

您可以通过点击[工具栏]的[批量触发单]按钮打开批量触发单对话框。

批量触发单主界面如下图所示：

触发单分为以下四种类型：吊买、吊卖、追买、追卖。

每个触发单在发送时需要输入以下参数：

  • 触发价格：触发单设定的条件价格，通过比较现价和触发价格确定是否下单。下单之后，该触发单会从交易服务器中删除；

  • 执行价格：条件满足之后，发送委托的价格，设定为0可自动获取当时的叫买/卖价；

  • 触发单类型：设定触发单的类型。

  • 触发单条件：设置触发单条件，满足触发单条件后，触发单将被触发并执行。

注意: 触发单在发送之后只在当日有效，该委托单在服务器上运行，此时您关闭程序或电脑不会影响触发单的执行。

吊买

吊买是指当现价向下跌破触发价格，即按执行价格产生一个即时买入委托单，如下图所示：

吊卖

吊卖是指当现价向上突破触发价格，即按执行价格产生一个即时卖出委托单，如下图所示：

追买

追买是指当现价向上突破触发价格，即按执行价格产生一个即时买入委托单，如下图所示：

追卖

追卖是指当现价向下跌破触发价格，即按执行价格产生一个即时卖出委托单，如下图所示：


交易助手

提供未成交单的自动监控及后续处理功能。

您可以通过点击[工具栏]的[交易助手]按钮打开交易助手设置对话框。

交易助手主界面如下图所示：

交易助手的窗口包含以下内容：

  • 撤单设置：对撤单的时机进行设置。

  • 撤单成功后需处理设置: 对撤单成功后，是否重发，如何重发等信息进行设置。

  • 监控帐户: 对交易助手的帐户范围进行限定。

  • 监控范围: 对交易助手的作用范围进行限定。

  • 启动/关闭监控：是否启动未成交单处理，启动/关闭监控后，状态栏的交易助手图标会显示当前的状态。

  • 保存设置：对上面的各项设置修改后，点击[保存设置]保存设置信息。

注意: 当使用多台计算机进行交易时，不要同时对某个帐户下的某个商品在两台机器上启动交易助手，这样会导致撤单后重复发单的问题。


策略易

通过界面输入参数，不需要编写复杂繁琐的公式代码就可以轻松实现自动化交易。

您可以通过点击[工具栏]的[策略易]按钮打开策略易对话框。

策略易主界面如下图所示：

策略易的窗口包含以下五部分内容：

通用设置

  • 交易帐户：帐户下拉选择框，选择当前的交易帐户；

  • 商品选择：要进行交易的商品，先选择交易所，再选择商品代码，也可以通过点击键盘按钮进行快速设置，还可以直接从行情报价拖拉商品到本窗体上进行商品切换；

  • 模板管理：点击该按钮显示模板管理的菜单，可以进行模板管理，模板选择等操作；

  • 多空设置：点击多空字样按钮，进行多空选择；

  • 单笔数量：每次行情触发时对该商品交易的数量；

  • 最大仓位：最大的持仓数量；

  • 委托间隔：设定分步开平仓的时间间距；

  • 下单偏移：买入使用叫卖价，卖出使用叫买价，在这个基础上，为了保证成交，可增加一定的偏移值。

开仓设置

  • 价格触发：类似于批量触发单，设定触发价格，但价格达到条件即进行交易；

  • 区间限定：价格触发时为了降低成本，设定一个范围，只有当触发价格在这个范围内才进行交易；

  • 盘口量限定：条件满足时，判断对应的买卖盘数量是否足够，只有当盘口数量大于等于设定值才进行交易；

风险控制

  • 平仓基准价格：选择以什么价格作为平仓计算的基准价，可选择第一笔开仓价，或者所有开仓单的委托均价；

  • 止损：设定止损跳数，当亏损大于等于设定值，即进行止损平仓；

  • 止赢：设定止赢跳数，当盈利大于等于设定值，即进行止赢平仓；

  • 跟踪止损：当盈利大于设定跳数时，启动跟踪止损，跟踪止损可以按照百分比或固定跳数进行设置。当盈利缩小到设定值，即进行平仓操作。

平仓设置

  • 价格触发：类似于批量触发单，设定触发价格，但价格达到条件即进行交易；

  • 定时平仓：当时间达到设定值，进行平仓操作；

  • 盘口量限定：条件满足时，判断对应的买卖盘数量是否足够，只有当盘口数量大于等于设定值才进行交易；

状态监控

  • 当前头寸：当前的持仓头寸；

  • 盈利峰值价：开仓后盈利最大位置的价格，用于计算跟踪止损；

  • 开仓均价：所有开仓单的委托均价；

  • 第一笔开仓价：第一笔开仓单的委托价；

  • 统计信息：累计的平仓次数，关闭窗体后清零；

  • 更新：如果需要手工更改当前头寸，盈利峰值价，开仓均价或第一笔开仓价，修改后须点击更新按钮使设置生效；

  • 继续开仓：在产生任何平仓动作之后，该按钮将会变为有效，如果不清除该标志，将不会再进行任何开仓动作；

  • 启动、暂停：点击该按钮，即可启动策略易的监控，您可在中途暂停并进行参数修改。

小技巧

  • 分仓操作时，建仓过程中触发平仓将停止建仓；点击“继续建仓”可重置开仓标志恢复建仓；

  • 通过“更新”调整状态监控参数，可单独实现平仓操作或在策略过程中调整平仓基准价格等；

  • 使用案例: http://www.tradeblazer.net/article/28.html


价差下单

提供两个商品或三个商品的手动价差交易，可实现跨期套利，跨市套利，蝶式套利及跨月换仓等。

您可以通过点击[工具栏]的[价差下单]按钮打开价差下单对话框。

价差下单主界面如下图所示：

价差下单的窗口包含以下内容：

  • 帐户：多帐户选择树，选择需要进行交易的交易帐户；

  • 模板管理：点击该按钮显示模板管理的菜单；

  • 蝶式套利：点击该按钮将切换到蝶式套利；

  • 跨月换仓：点击该按钮将切换到跨月换仓；

  • 商品选择：要进行交易的商品，先选择交易所，再选择商品代码；

  • 商品数量：对要进行交易的商品设定数量，将根据该比例计算价差；

  • 交易数量：每次交易时发送委托的数量，实际对每个商品的交易数量会根据比例和单位自动设置；

  • 下单价格偏移值：买入使用叫卖价，卖出使用叫买价，在这个基础上，为了保证成交，可增加一定的偏移值；

  • 下单确认：选择该复选框，交易时会弹出下单确认框。需要快速下单时可取消选择该复选框，此时将会直接发送委托；

  • 买入，卖出按钮：点击按钮，发送套利单到交易所。

价差的买卖盘量是根据原商品买卖盘量的最小值计算而得到，比值则按照设定商品的权重（数量×最新价）相除。

跨月换仓模式下，多空都是相对于商品A而言。按照图上的商品举例，多头平仓即对al0904卖出平仓，对al0905买入开仓。

注意: 价差下单都是按照投机类型，同时发出两到三笔委托，发送的委托并不能确保成交，如果配合使用价位偏移值和交易助手，可实现绝大部分委托的成交，避免单边头寸的出现。


快速平仓

当您有持仓的情况下，可通过双击帐户管理的持仓统计页面的项目，进行快速平仓。

快速平仓页面如下图所示：

一键全平

当您有多个帐户，并且有不同商品持仓的情况下，可通过点击帐户管理的[一键全平]菜单项进行快速平仓。

一键全平页面如下图所示：

可通过点击帐户列表和商品列表中的选项进行持仓选择，设置平多平空选项和委托价格之后，点击平仓按钮，即对多个帐户的多个商品持仓进行快速平仓。


快速撤单

当您有未成交单的情况下，可通过双击帐户管理的当日交易页面的项目，进行快速撤单。

您可以通过以下几个方式调入快速撤单：

    1. 双击帐户管理的当日交易页面的项目，或者右键菜单，选择撤单；

    2. 直接打开交易师，在操作下拉框中选择[撤销订单]，进行快速撤单。

可通过点击钱袋图标按钮，切换到多帐户撤单的界面，在此界面，可对多个帐户的当前商品的未成交单进行选择，统一进行撤单。

一键全撤

当您有多个帐户，并且有不同商品委托单的情况下，可通过点击帐户管理的[一键全撤]菜单项进行快速撤单。


帐户管理

帐户管理是对用户的交易帐户信息进行管理，包括资金，持仓，委托等信息。可对多帐户进行集中管理，并在页面中提供了快速交易的通道。

您可以通过以下几个方式打开帐户管理：

    1. 点击系统菜单[查看]-[帐户管理]菜单项；

    2. 直接按快捷键F6，会显示或隐藏帐户管理；

帐户管理的主界面请参见主界面介绍。

帐户管理包括以下几个页面，可通过点击标签页进行切换。

帐户汇总

该页面显示当前登录所有帐户的汇总信息，每个帐户项目的第一列显示了如下的图标：

  • ：显示当前选中帐户（联机）；

  • ：显示其他帐户（联机）；

  • ：显示当前选中帐户（断线）；

  • ：显示其他帐户（断线）。

通过双击列表中的项目，可将当前帐户项设定为选中帐户，此时其他五个页面显示的信息都是和选中帐户相关。

帐户汇总页面的右键菜单项如下：

  • 批量下单：直接打开批量下单；

  • 一键全平：对所有帐户，所有持仓进行快速平仓；

  • 一键全撤：对所有帐户，所有委托单进行快速撤单；

  • 自动排列：对列表字段根据长度进行自动排列；

  • 显示网格：显示列表中的网格；

  • 显示交易费用：显示交易手续费；

  • 显示当日出入金：在列表中显示出入金信息；

  • 显示风险信息：在列表中显示风险信息；

  • 显示市值信息：在列表中显示市值信息；

  • 刷新：刷新帐户信息和持仓信息；

  • 登出帐户：退出当前选中帐户；

  • 保存到文件：将列表的内容保存到文件中。

持仓信息

该页面显示选中帐户的持仓信息，选中持仓项目，右键菜单包括如下菜单项：

  • 当前帐户：设定当前帐户，在多帐户情况下，可选择不同帐户切换当前帐户，其功能等同于在帐户汇总页面双击帐户项；

  • 持仓信息：按选中类型显示持仓信息；

  • 批量下单：用当前商品打开批量下单，如果无选中商品，则直接打开批量下单；

  • 一键平仓：对当前选中商品进行快速平仓；

  • 一键全平：对所有帐户，所有持仓进行快速平仓；

  • 多头平仓：对当前所选中商品增加一个多头平仓止赢、止损触发单；

  • 空头平仓：对当前所选中商品增加一个空头平仓止赢、止损触发单；

  • 自动排列：对列表字段根据长度进行自动排列；

  • 显示网格：显示列表中的网格；

  • 显示帐户：在列表中显示帐户字段；

  • 保存到文件：将列表的内容保存到文件中。

  • 显示多仓信息：在列表中显示多仓信息；

  • 显示空仓信息：在列表中显示空仓信息；

  • 显示市值信息：在列表中显示市值信息；

  • 刷新：刷新帐户信息和持仓信息；

您也可以直接双击持仓项目进行快速平仓。

当日交易

该页面显示选中帐户的当日交易情况，包括所有的委托，成交，撤单，废单等信息，选中委托项目，右键菜单包括如下菜单项：

  • 当前帐户：设定当前帐户，在多帐户情况下，可选择不同帐户切换当前帐户，其功能等同于在帐户汇总页面双击帐户项；

  • 商品过滤：显示选中的商品交易信息；

  • 批量下单：用当前商品打开批量下单，如果无选中商品，则直接打开批量下单；

  • 撤单：对当前选中商品进行撤单，只有当状态为未成交时有效；

  • 一键全撤：对所有帐户，所有委托单进行快速撤单；

  • 显示类型：设置当前列表显示内容的类型，可选择以下类型：全部、委托单、成交单、已撤单；

  • 自动排列：对列表字段根据长度进行自动排列；

  • 显示网格：显示列表中的网格；

  • 显示帐户：在列表中显示帐户字段；

  • 显示成交信息：在列表中显示当前委托的成交信息；

  • 显示开平标志：在列表中显示开平标志信息；

  • 显示投机保值：在列表中显示投机保值信息；

  • 显示注释信息：在列表中显示委托单的注释信息；

  • 成交统计：对所有帐户，所有成交单的信息进行统计；

  • 保存到文件：将列表的内容保存到文件中。

您也可以直接双击委托项目进行撤单或交易。

触发单

该页面显示选中帐户的触发单情况，选中触发单项目，右键菜单包括如下菜单项：

  • 当前帐户：设定当前帐户，在多帐户情况下，可选择不同帐户切换当前帐户，其功能等同于在帐户汇总页面双击帐户项；

  • 批量下单：用当前商品打开批量下单，如果无选中商品，则直接打开批量下单；

  • 撤单：对当前选中商品的触发单进行删除；

  • 一键全撤：对所有帐户，所有委托单进行快速撤单；

  • 显示类型：选择显示当前正在运行的触发单或者全部的触发单；

  • 自动排列：对列表字段根据长度进行自动排列；

  • 显示网格：显示列表中的网格；

  • 显示帐户：在列表中显示帐户字段；

  • 显示开平标志：在列表中显示开平标志信息；

  • 显示投机保值：在列表中显示投机保值信息；

  • 显示注释信息：在列表中显示触发单的注释信息；

  • 保存到文件：将列表的内容保存到文件中。

您也可以直接双击触发单项目进行修改或删除触发单。


银期转帐

提供银期转帐业务，可以实现出金和入金。

银期转帐主界面如下图所示：

银期转帐的窗口包含以下内容：

  • 交易帐户：选择需要进行出入金的交易帐户；

  • 银行帐户信息窗口：选择需要转帐的银行帐户；

  • 转帐类别：选择出金或者入金；

  • 转帐业务信息窗口：显示提交转帐的业务请求信息和状态。


操作小技巧

操作小技巧提供一些使用交易开拓者的操作提示，在这里您也许可以有意想不到的收获。您可以通过系统菜单[文件]-[操作小技巧]打开。

点击[下一条]可显示下一条操作提示。


用户字段

用户字段作为一种特殊用途的公式，它主要用于在报价类窗体中使用，最大的特点在于：用户字段不像其他公式，它只需要最后一个Bar的输出数据，而不是所有Bar的输出数据。因此，对于用户字段的处理和其他公式都不相同，我们对用户字段的使用规则归纳如下：

  • 支持三种基本类型的参数定义，支持指定参数默认值；

  • 不支持使用引用参数；

  • 支持六种类型的变量定义，支持指定变量的默认值；

  • 可以访问Data0-Data49个数据源的Bar数据；

  • 可以访问行情数据属性数据；

  • 必须通过FieldNumeric、FieldBool、FieldString返回数据，返回数据类型为三种基本类型的组合；

  • 可以支持Alert来进行报警；

  • 用户字段可以调用所有的用户函数进行计算；

  • 用户字段可以根据设置调用部分的系统函数；

  • 用户字段在执行时，必须要指定相应的数据源和周期，需要调用历史数据的，只有历史数据存在的情况下才能返回正确的值。

例如，用户字段Field1计算最近5个Bar的收盘价的最大价,用户函数Highest计算最大值。脚本如下：

Params
    Numeric Length(5);
Vars
    Numeric HighValue(0);
Begin
    HighValue = Highest(Close,Length);
    FieldNumeric("Highest Bar", HighValue);
End

在用户字段中只能输出一组数据，该组数据通过FieldNumeric/FieldBool/FieldString的第一个参数：输出值的名称来进行识别，在一个用户字段中，不能出现两个不同的输出值名称，以下为错误的代码：

FieldNumeric("Test1",Close);
FieldNumeric("Test2",Open);
FieldBool("Test1",True);

以下为正确的代码：

FieldNumeric("Test1",10);
FieldBool("Test1",True);
FieldString("Test1","Test String");

FieldNumeric

参见FieldNumeric。

FieldBool

参见FieldBool。

FieldString

参见FieldString。

Alert

参见Alert。


行情数据

除了Bar数据之外，TradeBlazer公式还可以支持实时行情数据的调用，行情数据是指当前商品最新的报价数据，该数据和Bar无关，行情数据的回溯没有意义。

行情数据只在最后Bar是有意义的，其他Bar会返回无效值。因此，在调用行情数据函数时，为了提高效率，最好按照以下方法：

If(BarStatus()==2)
{
    //调用行情数据函数
}

行情数据函数都按照以下格式命名Q_XXXXX，比如Q_Close，Q_BidPrice。在调用行情数据的时候，需要判断当前行情数据是否有效，系统提供函数QuoteDataExist来对有效性进行判断。如果行情数据已经准备好，返回True,否则，返回False。